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Abstract 

A user's ability to generalize his experience"s with a computer system to new tasks is 

directly related to the robustness of the mental model he forms while learning to use the 

system. If designers don't account for the variety of user goals and preconceptions that 

will be brought to software when it is first learned, the system model built into the software 

will be ineffective. This paper proposes as a solution to this problem, a "bootstrapping" 

interface: an integrated interface and on-line help system which identifies user 

preconceptions and goals and encourages users to develop a model of the system which 

coherently incorporates these preconceptions and goals. This paper outlines the design 

methodology used to develop a prototype of a "bootstrapping" word processor. Nine 

subjects tested the prototype for usability, successfully completing assigned tasks despite a 

variety of backgrounds and incomplete instruction on use of the word processor. Insight 

was gained into user preconceptions in the domain of word processing, and the prototype 

design was improved. 



2 

Problem Statement 

It is widely believed that users fonn a mental model of a system as they learn to use it 

(diSessa, 1986; Lewis, 1986; Norman, 1986; Owen, 1986; Riley, 1986). This model is 

used to predict the behavior of the system as the user attempts to carry out new tasks. The 

user's ability to generalize his experiences to new tasks is directly related to the robustness 

of his mental model of the software. 

Designers of software systems are faced with the task of developing a system model 

which projects a consistent, coherent image from which the user will construct his mental 

model. Designers have interpreted this task as meaning they must create a system which 

projects a single system model, the one which is most appropriate to the software and the 

average user. Norman (1986) and Owen (1986) have pointed to the learning period of 

system use as the stage in which a mental model is the most useful. A designer's model, 

no matter how coherent, will not assist the user in learning the system if it differs widely 

from the user's preconceived ideas about the software and the software domain. 

Different users prefer different software systems for performing similar tasks, use the 

same software toward different ends, and approach a new software package with personal 

sets of preconceptions developed in years of experience with the world. All of these 

factors must be considered in designing a system model, or the model will be ineffective in 

the most crucial period of software use. 

The field of human-computer interaction will benefit from the development of a 

design methodology which uses the study of user preconceptions and their manifestations 

to develop interfaces designed specifically to aid users in the early stages of software use. 

Such an interface could be referred to as a "bootstrapping" interface, as the uninitiated user 
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will be able to "pull himself up by the bootstraps" in the learning phase of software use, 

requiring little or no formal instruction to successfully learn the software. 

This paper outlines a design methodology for the development of a "bootstrapping" 

interface, and describes the early phases of the development of a "bootstrapping" word 

processor. The chosen user audience is college students who are taking a composition 

course. College students taking a composition course are an interesting audience for 

several reasons. First, they are trying to learn the difficult task of writing. They are neither 

experts nor novices in this domain, but they have preconceptions about their task, as they 

had writing assignments in secondary school. They have preconceptions about the tools 

used for the task, whether they have used pen and paper, the typewriter, a word processor, 

or some combination or subset of these tools. Word processing is an interesting domain 

because the word processor is the most crucial software tool used by the chosen audience. 

The majority of students in college today are required to write with a word processor, 

despite the possibility of little or no previous experience with the tool and little time to 

learn. There are many word processors available for study and for example of interface 

and functio'nality choices. 

There have been numerous studies on the effects of computer writing tools on user 

writing attitudes, writing ability, and revision strategies (Baer, 1988; Bridwell, Sire, and 

Brooke, 1985; Hansen and Haas, 1988; Harris, 1985; Hawisher, 1987; Lutz, 1987). 

These studies conclude that while users enjoy using the word processor and feel that it 

improves their writing, there is little or no change in writing ability and revision strategy. 

The users studied generally adhered to old strategies and adopted them to the software they 

were using. These fmdings point to writing as a challenging domain for the development 

of a "bootstrapping" interface, as users can be expected to hold fast to their individual 

preconceptions. 
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Thesis 

Design Models for a "Bootstrapping" Interface 

In order to develop a "bootstrapping" interface, a designer must be able to answer the 

following questions: 

1.	 What are the possible backgrounds that users might have? 

2.	 What models do these backgrounds bring to the software domain? 

3.	 Can each model be integrated into the design, and if not, what is the best possible 

model to use in interacting with the user who has this background and model? 

4.	 How are the backgrounds and models recognizable in task execution? 

The answers to these questions provide the designer with the raw infonnation from 

which the software model, the user model, and a system-user interaction strategy can be 

forged. In examining user backgrounds, the designer learns terminologies and 

methodologies that are familiar to users of different backgrounds. By studying the models 

of users with these backgrounds, the designer gains insight into user expectations and 

strategies. This insight is used to develop an interface which projects multiple system 

models, each appropriate to a different user background. The software must have the 

ability to recognize a user's background in order to interact with him in a suitable manner. 

Help strategies are designed to reinforce the user's model and teach task-achievement 

methods which are in concordance with this model. If it is impossible for the designer to 

accommodate a user's background, there must be a scheme for guiding the user to a 

different, but similar, model. 
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The developed system projects multiple system models and has strategies for 

recognizing the user's mental model of the system, and for tutoring users with different 

models of the system. In order to have an interface I help system which classifies and 

helps the user according to preconceptions and goals, a set of user models and tutoring 

strategies must be maintained in the system. in addition to a profile of the current user. 

The only way for the system to non-intrusively discover the current user's mental 

model is through his use of the system. It is therefore appropriate to model the user as his 

method of interaction with the system, and assume that this is an approximation of his 

mental model of the system. If the user is a novice with the software, his interaction with 

the system is an approximation of his preconceptions, background, and expectations. 

Precisely how the "user's interaction" is to be represented depends- on the software 

domain. Generally, the user's interaction can be represented as a set of smaller 

interactions, each denoting a task which can be achieved in the domain. These interactions 

are characterized by the task to be achieved, the method of task achievement, general 

strategies which affect the achievement of the task, and the language used to describe and 

conceprualize the task. . 

A Methodology for the Development of a "Bootstrapping" Interface 

The four questions above can be answered only through study of the domain and the 

target population. Potential task-achievement methods and their associated terminology and 

strategies must be abstracted from the study of the domain. As much of this user 

interaction data as possible must be incorporated into the design, without "cluttering" the 

design, and without causing obvious conflicts. Naturally, the issues of "clutter" and 

"conflicts" are subjective. The designer has to use his best judgement, and then allow 

testing to illuminate problem areas. The following method for developing a 
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"bootstrapping" interface will guide the designer in discovering appropriate user-interaction 

data and successfully incorporating these data into a design. 

1.	 Study the domain, focusing on the previous tools and methods used to perform tasks 

in the domain, language used to describe tasks in the domain, and general strategies 

employed to solve problems in the domain. 

2.	 Develop prototypical situations on the target computer. Central to each situation is a 

common task to be J?erformed on the computer, for which several methods of task. 

execution have been implemented, each corresponding to a different user model. 

3.	 Execute usability testing on the prototypical situation, testing several users with a 

variety of background experiences. 

4.	 Determine if the implemented methods and their corresponding models were 

appropriate. 

5.	 Record any methods attempted by the users which were not provided in the 

prototype. 

6.	 Resolve ambiguities in the user's methods, if possible, and add the user's methods to 

the interface and help system, including recognition and tutoring schemes. If this is 

not possible, add a recognition scheme, and assign the user an approximate model for 

tutoring. 

7 .	 Develop a fully functional system based on the prototypes and repeat steps 3 through 

6 to test and improve this system. 

8.	 Execute advanced testing on the final system, studying the ,effectiveness of the system 

after long periods of use and comparing the system to othet tools in the domain. 

The Prototype for a "Bootstrapping" Word Processor 

For this project, the prototype of a "bootstrapping" word processor was developed 

and tested, fulfilling steps one through six of the methodology described above. The 
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purpose of this project was to demonstrate that "bootstrapping" software is a practical, and 

potentially superior, alternative to software which forces the user to adopt the designer's 

domain model. The prototype, therefore, confonns to the concepts described above, but 

does not incorporate pioneer methods in the style of on-line help provided. 

The Domain Study 

The purpose of the domain study is to learn about previous tools and methods used to 

perfonn tasks in the domain, language used to describe tasks in the domain, and general 

strategies employed to solve problems in the domain. This information is used to develop 

an interface which projects multiple system models, and a help system which recognizes a 

user by his method of interaction with the word processor, and interacts with the user 

accordingly. 

In the domain of writing, the most common tools are pen or pencil and paper, the 

typewriter, and the word processor. These tools are used individually or in combination. 

There is a large variety of word processors and typewriters, offering a variety of task­

achievement procedures, language, and strategies for the achievement of similar tasks. 

When correcting drafts on paper, an assortment of symbols are used to indicate changes to 

be made to texts. Some of these symbols are universal, others are unique to an individual 

or group. A multitude of task-achievement data can be gleaned from the study of these 

areas. 

To study task-achievement methods in writing, tasks were divided into two writing 

categories: editing and formatting, and three word processing categories: filing, selecting, 

and moving through a document. For each task in the writing categories. four or more 

methods were listed: the Macintosh word processor method, the "other" word processor 

method (meaning popular word processors, such as Microsoft Word for the ffiM PC), the 
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typewriter method, and the pen / pencil and paper method. For example, for the editing 

task of moving a block of text, the Macintosh word processor method is to select, cut, 

move the insertion point, and paste. The "other" word processor method is a similar cut 

and paste operation, a copy / delete and paste operation, a move operation, or the user 

could delete and retype with any word processor. There is no typewriter method. and with 

pen and paper, the "user" might draw a circle around the block to be moved, and an arrow 

to its new location (a typewriter user might also use this method. before retyping). For the 

tasks in the word processing categories, mostly word processors were considered, 

although icons and commands representing events that might occur with pen and paper or a 

typewriter (such as turning a page) were also considered. 

A questionnaire (Appendix A) was designed to discover user backgrounds and the 

associated language used in describing tasks. The questionnaire consists of two sections: 

one multiple-choice and fill-in-the-blank section to discover the user's background (users 

were divided into the following backgrounds: pen / pencil and papers users, pen / pencil 

and paper and typewriter users, typewriter users, pen I pencil and paper and word 

processor tIsers, word processor users, and typewriter and word processor users), and the 

other consisting of before and after "pictures" of text-ed.iting and text-formatting situations, 

under which the user was instructed to describe what had happened between the pictures. 

The questionnaire was completed by 179 college and high-school students, most of whom 

had little experience with word processors. 

Seven of the twenty-five before I after questions were studied for language used to 

describe word-processing tasks (these were the most relevant questions in light of the 

reduced functionality of the prototype as compared with a fully-functional word processor). 

Although there were some trends which linked background with language, this occurred 

mainly with the computer users. The computer users and non-computer users alike 
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generally used individua~ and unique language. For each question, two issues were 

considered: the verb used to describe the transfonnation, and the noun used to describe the 

block of text. Following is a brief summary of the data gathered from the seven questions 

studied. 

Question six consists of the following graphic: 

What he had once hoped for What he had 
the Flock... 

once hoped for 
the Flock... 

For the verb, or transfonnational word, one hundred and forty-four responses 

included the word enlarge, large, or big. Thirty-two responses included "word processor" 

words such as style, bold, font, and size (the majority of these were pen / pencil and paper 

and word processor users, some of the "bold" and "size" responses were from non-

computer users). The most commonly used nouns were type, letters, sentence, print, or 

words (one hundred and thirty-one responses). 

Question nine consists of the following graphic: 

What he had acne .• What he had once•.•4 

One hundred and ttiny-three responses mentioned spelling or correction (about a 

third of these were from students who had used a word processor previously, so no trends 

linking background and language were discovered here). Seven responses used the word 

"switch." For nouns, thirty-one used "word." six used "letter," and three used "mistake." 

The remaining responses did not include a noun, mentioned "once" explicitly, or used the 

"before" column or the "after" column as the noun. 
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Question eleven consists of the following graphic: 

What he had once hoped for What he had once hoped for 
the Flock... the Flock". 

One hundred and seventy-one responses indicated that the fragment had been 

underlined. Of the ninety-nine responses which included a noun, eighty-eight used one of 

the following nouns: phrase, fragment, sentence, word, passage, or statement. Only four 

responses included the noun "text," two of these responses were from word processor 

users, and two were from pen / pencil and paper and word processor users. 

Question twenty-four consists of the following graphic: 

What he had once hoped What he had once hoped for 
for the Flock, he now the Flock, he now gained for 
gained for himself alone; himself alone; he learned to 
he learned to fly, and fl~, and was not sorr~ for 
was not sorry for the the price that he paid. 
price that he paid. 

Although many of the responses described only the size change, one hundred and 

fony-seven<'described the change in typeface. Of those, the verb was usually "change," 

and therefore not very interesting. The noun was usually print (fifty-four responses), type 

(twenty-nine responses), or the response described the new typeface as "lighter" (twenty 

responses), italics (eighteen responses), or boldface (seven responses). Eleven responses 

used the word font. Of these, four were strict word-processor users (out of six total strict 

word-processor users), five were pen / pencil and paper and word processor users (out of 

thirty-nine total), one was a typewriter and word processor user (the only oue), and the last 

was a pen / pencil and paper and typewriter user who had previously used a word 

processor. Many of the responses were phrased badly, indicating that the student had no 

language available for describing a typeface change. The following are some examples: 
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"form of writing changed" 

"the words in the second fonn were lightened in color, and were also fitted together 

to make a smaller paragraph" 

"the first one is regular writing the second they put in fancy writing" 

"it's in a different way of print" 

Question twenty-six consists of the following graphic: 

What he had once hoped. What he had once hoped
 
for the Flock, he now got for the Flock, he now
 
for only himself; gained for himself alone;
 

One hundred and two responses used the nouns "word" or "sentence." Five others 

used one of the following nouns: statement, excerpt, or paragraph. The remaining 

responses described the transfonnation using the exact words which were changed. 

"before" column and "after" column, or used no noun at all. Fony-three responses used 

the verb "change," thirty-seven used "add," and sixteen used one of the following verbs: 

correct, replace, or reword. Nineteen responses indicated that the wording had been 

improved. One response used the verb "edit" (a pen / pencil and paper and word processor 

user). 

Question twenty-seven consists of the following graphic: 

What he had once hoped for Jonathan Seagull discovered
 
the Flock, he now gained for that boredom and fear and
 
himself alone; he learned to anger are the reasons that a
 
fly, and was not sorry for gull's life is so short, and
 
the price that he paid. with these gone from his
 

thought, he lived a long fine 
life indeed. 

Jonathan Seagull discovered 
that boredom and fear and What he had once hoped for 
anger are the reasons that a the Flock, he now gained for 
gull's life is so short, and himself alone: he learned to 
with these gone from his fly, and was not sorry for 
thought, he lived a long fine the price that he paid. 
life indeed. 
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One hundred and twenty-two responses indicated switching; Sixty-nine used the 

verbs "switch" or "swap," and fifty-three used one of the following verbs: flip, rearrange, 

revise, or order. These responses were from a homogeneous mixture of students who had 

and had not used a word processor previously. Two responses used the verb "move," 

these were both pen / pencil and paper and word processor users. Three responses used 

"cut and paste," these were either pen / pencil and paper and word processor users, or strict 

word processor users. Of the one hundred and forty-five responses which included a 

noun, one hundred and thirty-five used "paragraph," five used "sentence," four used 

"section." and one used "stanza." 

Question twenty-eight consists of the following graphic: 

What he had once hoped What he had once hop2d 
for the Flock, he now for the Flock, he now 
gained for himself alone; gained for himself alone; 
he learned to fly, and 
was not sorry for the 
price that he Paid. 

Ninety-two responses contained a verb describing the transformation. Of these, forty 

used one of the following verbs. indicating that part of the text had been deleted: deleted. 

dropped, cut. eliminated, omitted, excluded, removed. One response used the word 

"erase," and twenty-seven wrote that some of the text had been left out, taken out, or taken 

away. Seventeen used the following verbs which indicated revision: shortened, 

condensed, revised. One hundred and fourteen responses included a noun. Fifty-three of 

these used the noun "paragraph," and twenty-five used the noun "sentence." Twenty­

seven used one of the following nouns: line, statement, phrase, word, or passage. Five 

used the noun "text," all of whom were strict word processor users, or pen / pencil and 

paper and word processor users. Four used either "infonnation" or "material." 
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The Prototype Design 

The functionality of a word processor was divided into five categories: editing, 

formatting, filing, selecting, and viewing the text. Two of these categories, editing and 

formatting, are familiar to users of all backgrounds (even if, to a pen I pencil and paper 

user, fonnatting means drawing a line under a title). Filing, viewing, and selecting are 

tasks that are familiar primarily to word processor users. Methods were prototype(! for the 

word processor users, and an attempt was made to accommodate users who will be 

unfamiliar not only with the procedures to be followed, but more importantly with the 

concepts of filing, viewing, and selecting. Experimentation is necessary to discover what 

methods the non-word processor users find most intuitive. 

In the prototype, editing commands on the level of cut and paste are provided (cut. 

copy, paste, and keyboard editing). No advanced editing commands, such as global search 

and replace and spell-checking, were prototyped. In order to accommodate the different 

user backgrounds considered, a variety of commands were prototyped that aren't available 

in standard Macintosh word processors. The following procedures were developed for the 

"other" word processor users, the typewriter users, and the pen / pencil and paper users: a 

move procedure, a duplicate procedure, a replace procedure, and a delete procedure. Thus 

there are several methods available for performing each goal-level task, such as moving, 

replacing, and revising. 

As with editing, a sharply reduced functionality is provided for formatting in the 

prototype. The prototype has the capability to change character size, typeface, and style; 

leaving margins, tabs, line spacing, paragraphs, alignment, and special graphics 

capabilities unimplemented. To change the typeface, style, or size (all of which require the 

same method), four methods are provided. The first is a standard Macintosh method: 

select the desired style, size, or font from the appropriate menu (usually there is a Font 
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menu and a Style menu, in this word processor there is a Set Type Style menu), then type 

the text. The other standard Macintosh method is to select the text, then choose the style, 

size, or font. If the user has not demonsuated the meta-skill (or suategy) of selecting text 

before choosing an operation, he will be guided through the operation, allowing both 

methods described above. 

Selecting is one of the categories that, conceptually as well as methodologically, will 

be novel to users unfamiliar with a word processor. For word processor users, standard 

Macintosh selection is provided. This includes pressing and dragging with the mouse, 

double-clicking (to select a word), and shift-clicking (to extend a selection from the 

previous selection or from the insenion point). New users invariably have difficulty 

learning to select text (personal experience), sometimes because they don't understand to 

select text before choosing an operation, and sometimes because they aren't yet accustomed 

to the mouse. A second method is provided for the non-word processor users, but is 

strictly experimental as users will have few preconceptions about a task which they have 

never been required to perfonn. This second method is a Select menu, with items which 

allow selection of the whole document, a word, a sentence, a paragraph, or "some text" 

Although viewing will be familiar to users with all backgrounds, only word 

processor users will be comfortable with the notion of a screen of text (as opposed to a 

page or line). Three methods were prototype<! for viewing different pans of the text: the 

standard Macintosh scroll bar, the View menu, and the keyboard equivalents for the View 

menu. The View menu consists of four commands: Previ6us Screen, Next Screen, 

Previous Line, and Next Line. The prototype does not provide the ability to see what text 

will constitute a page when printed, so no page-viewing commands were prototyped. Also 

provided is the standard scrolling which occurs on the Macintosh when you type above or 

below the screen, and when you select above or below the screen. The scroll bar was 
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provided for Macintosh users, and the View menu and keyboard equivalents were provided 

for "other" word processor users, who might be more familiar with "Page up," "Screen 

up," and similar commands. In order to determine what would be preferable to non­

computer users, more testing has to occur. 

It has been observed that when learning the Macintosh (personal experience), users 

frequently "lose" their text (what they have typed is no longer visible on the screen), 

through accidental use of the scroll bar, pressing the return key, closing the document, or 

moving the window. Carroll and Carrithers found that creating a training system, in which 

certain error states are unreachable, resulted in faster learning and improved comprehension 

(Carroll and Carrithers, 1984). An attempt was made to alleviate the window-moving 

problem by reducing the functionality of the word processor. The prototype does not allow 

movement or resizing of the window by the user. It is possible that the other problems 

could be alleviated by including a help choice "What if I lose my text?" This requires more 

study of beginner users and the questions they ask when they lose their text, and what they 

respond to in order to fmd their text 

Filing tasks were virtually ignored for this prototype; only one method of saving, 

opening, closing. and getting a new window was implemented: the standard Macintosh 

method. A fully-functional word processor was designed which provided multiple 

methods of accomplishing these tasks, but the fully functional word processor was not 

prototyped. Formatting and editing tasks are more interesting because they are familiar to 

users with a variety of backgrounds, and because of limited time and a limited number of 

test subjects, emphasis had to be placed on these areas in the prototype. 

The prototype screen consists of three windows (one with a scroll bar), a menu bar. 

and a palette of command icons (see Figures 1 and 2). The fIrst window is the text-editing 
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window, into which the user may enter and edit text. This window has a standard 

Macintosh scroll bar which consists of a bar with a "thumb" indicating the position of the 

current screen in relation to the entire document The scroll bar allows continuous scrolling 

(by pressing in the arrows at the top and bottom), next and previous line scrolling (by 

clicking in the arrows at the top and bottom), next and previous screen scrolling (by 

clicking in the gray area above or below the thumb), and thumb-dragging to reach a screen 

in the document immediately. The text-editing window title is currently "UntitledX," or the 

name of the document if it has been saved to disk (named). In a fully-functional version of 

the prototype, the window title would contain information about the last time the document 

was written to disk. 

The Clipboard window is a temporary holding place for text which has been Cut, 

Copied, Duplicated, or Moved. The Clipboard window appears whenever a new item is 

written to it during one of these procedures, or if the user explicitly requests to see the 

Clipboard by choosing "Show Clipboard" from the Edit menu. Once displayed, the 

Clipboard remains displayed until the user chooses "Hide Clipboard" from the Edit menu. 

The Clipboard window title changes in accordance with its contents. If text has been Cut to 

the Clipboard.. the Clipboard window title is "Clipboard: Cut Text." The title changes 

similarly for copied, duplicated, and moved text. The decision to display the Clipboard 

after each Clipboard-affecting operation was made as an attempt to attenuate new user 

misconceptions about the Clipboard. The Clipboard concept is a word processing standard 

which has no meaning in the domain of writing. In his study of student modeling of word 

processors, R.L. Upchurch found that users, even after a semester of writing on the word 

processor, do not have robust models of the Clipboard and the operations that can be 

performed on it (personal communication, July, 1989). 
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The Instructions window is a small window which appears at the top of the screen. 

accompanied by a menu bar flash and a system beep. whenever the user chooses a 

command which consists of several steps. The OK and Cancel buttons appear at the top of 

the control panel and remain visible while the Instructions window is visible. The 

Instructions window disappears after the user has completed the task for which he has been 

given instructions. The user signifies completion by pressing in either the OK or Cancel 

buttons. For example. the Move command requires that text be selected. then a place 

chosen for the new text. If Move is chosen with text selected. the Instructions window 

instructs the user to click where the text should be moved. then to click in the OK button. 

If Move is chosen without text selected, the Instructions window asks the user to fIrSt 

select text. then click OK. then click where the text should be. and click OK. Clicking in 

the Cancel button cancels the operation. 

With any software package. task accomplishment consists of selecting an object and 

choosing an operation to perfonn on the object IIi a word processor, objects are blocks of 

text. and operations are editing. formatting. moving. selecting. and filing commands. In 

the "bootstr'apping" prototype. there are two ways to select an object; using standard 

Macintosh text-editing techniques. and the Select menu. There are also two ways to choose 

operations. Most operations can be chosen from the palette. or from a menu. Viewing 

options can be chosen from the menu, or using the scroll bar. Language issues shaped the 

wording of the Select menu, and the decision to have a graphical palette. The Select menu 

provides selection ofwords, sentences, and paragraphs. because these are the units into 

which questionnaire responses decomposed blocks of text (the noun responses), regardless 

of background. Although certain verbs were used exclusively by word processor users, 

most language was individual. A graphical palette does not attempt to describe graphical 

operations with short bursts of language, but with icons representing the operations to be 

accomplished. Care was taken to use icons which would be universally familiar, and many 
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word processor users were polled during the design of the palette to determine the most 

preferred and recognizable icons. 

One general goal-achievement strategy in the domain of word processing was 

identified; the preference of when to choose the operation in relation to the choice of 

object. Some users are more comfortable with choosing the object first (the standard 

Macintosh method), others prefer to choose the operation first. Both methods are 

implemented in the prototype, the operation-before-object method being facilitated by the 

Instructions window (see Figure 2). The non-computer users were considered in 

implementing the operation-before-object method, as it has the potential to help them adjust 

to the unfamiliar notion of selecting text. 

In order to help users based on their preferred methods and strategies, a record must 

be maintained of the current user and the methods and strategies employed while using the 

word processor. To teach this user task-achievement methods which are in concordance 

with his model, infonnation must be available which links his methods and strategies to 

methods anti strategies that can be used to solve problems he hasn't yet encountered. 

For the prototype, a list of word processor "events" (Wp events) was created (See 

Table I for the list of WP events). Each WP event is a unit that can be used in the 

construction of one or more task-achievement methods. A list of upper-level tasks was 

created, and for each upper-level task, task achievement methods, composed ofWP events, 

were listed (see Table 2 for the list of task-achievement methodh For example, there are 

eight methods of replacing text. One of these methods is to press the delete key, and then 

retype. Another method is to select text, then choose Replace (frnm the Edit menu or the 

palette), then type the new text, and press OK. 
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When the user completes a task, the method of task achievement is recorded in the 

current user help profile. For the simple purposes of the prototype, user preferences were 

considered to be the number of times a given task achievement method was used, compared 

with the total times that task was accomplished. In the future it would be wiser to have task 

achievement methods weighted and losing weight over time, so that as the user learns, he 

isn't plagued by his early conceptions. 

The user can request help by choosing from the Help menu, or by clicking in the 

Help button in the palette. Choosing Help invokes a series of dialog boxes: modal 

windows which require a response before the user can continue using the software. The 

dialog boxes force the user to specify what task he needs help accomplishing, then a dialog 

box appears, describing a method of task accomplishment. Cutting edge help techniques 

were not considered for the prototype, as the purpose of the prototype is to demonstrate the 

viability of "bootstrapping" software. 

When the user specifies the task he needs help accomplishing, the help procedure 

checks to see what tasks the user has accomplished previously. Tasks, and in some cases 

specific task-achievement methods, are linked into logical units by similarities in 

achievement methods, results, and purpose. For example, if the user requests help 

switching passages, and he hasn't moved text previously, the help procedure will check to 

see if he's duplicated. Duplication has the same achievement method as moving, and a 

similar purpose, but different results. 

The task-achievement help message has five parts: reminder, first, next, finally, and 

results. The reminder pan of the message reminds the user of the task he's accomplished 

which is similar, and explains, in general terms, what the difference is between the task 

previously accomplished, and the task about which help was requested. If the user hasn't 
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performed a task even remotely similar to the task about which help was requested, the 

reminder will simply say "You can use the following method to [accomplish task]." The 

fIrst, next, and finally parts of the message describe the steps for accomplishing the task. 

Some methods don't require this many steps for explanation. The results pan of the 

message describes what will happen after "fInally." This provides the user with the 

opportunity to determine if he is reading the right help screen for his task, and the tools to 

determine if he's followed the procedure correctly, once he tries to follow the help advice. 

In two instances, there will be ambiguity about command meaning, depending on the 

user's general strategy of object / operation selection timing. These instances are when the 

user is Pasting (does he expect the contents of the Clipboard to be pasted at the insertion 

point when he chooses Paste, or does he expect to choose Paste and then click where he 

wants the contents of the Clipboard) and when the user is choosing a type font, style, or 

size without previously selecting text (does he expect to begin typing in the new style, or 

does he expect to be able to select text after choosing). The prototype maintains this 

information about the current user. The user is assumed to have the operation-before­

object strategy unless he selects text and chooses a palette or menu operation. The first 

design of the prototype did not consider selecting text before choosing a font, size, or style 

as contributing toward this strategy information, as selected text can be a side effect of 

other operations (e.g. Copy), and therefore the user's intentions were ambiguous. If the 

user has the operation-before-object strategy, whenever Paste or a font, size, or style is 

chosen, the Instructions window appears, and then user must select the object and press the 

OK button. If the user has the object-before-operation strategy, the Instructions window 

does not appear on typeface or Paste choices. 

In order to study user interactions with prototyped situations, a recording facility 

must be available to the designer and invisible to the user. Because of time limitations, a 
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very simple recording facility was built into the prototype. The prototype records every 

WP event, and saves this list of events, as well as the user help profile, to disk. To 

supplement this meager recording scheme, observations were made and recorded by hand 

as the users tested the prototype. 

The majority of Macintosh software is event-driven. The prototype for the 

"bootstrapping" word processor is no exception. The main procedure is a loop which 

reads events from the Event Queue and responds accordingly. After every system event, a 

parser-like procedure is called to determine if a WP event occurred, updating the help 

profIle if necessary. The prototype was developed using THINK Pascal version 2.01. 

The event-response code, filing code, and utilities code was based on a text editor released 

as an example of Macintosh programming with TIUNK LightSpeed Pascal version 1.0, 

although there are few similarities between the TIDNK text editor and the "bootstrapping" 

word processor prototype. The code for the "bootstrapping" word processor prototype is 

provided as Appendix C. 

Usability Testing 

Usability testing. allows a designer to examine the viability of his design, exposing 

flaws which can be changed rapidly. In usability testing, the designer prototypes aspects 

of his design which he wants to test, then develops tasks which are realistic to the software 

domain, and will force the questionable portions of the design to be exercised extensively 

by his target audience. Several members of the target audience execute the task, then 

complete a questionnaire designed to draw out their perceptions of the software. In testing 

the "bootstrapping" word processor prototype, perceived flaws were corrected or 

circumvented between testing situations in order to maximize the value of testing. 
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In testing the "bootstrapping" word processor prototype, a test was designed to force 

the user to perfonn high-level editing and fonnatting tasks. Perfonnance of the editing and 

fonnatting tasks could lead to implicit viewing and selecting tasks, but these were not 

included explicitly as they are not writing goals. 

The user was seated in front of a Macintosh llcx with the word processor running 

and a short paper typed into the text-editing window. The user was instructed to read a one 

and one-half page description of the word processor. This description includes a paragraph 

explaining that the software is being tested, not the user, a paragraph describing the mouse, 

three paragraphs describing how to choose from the menu bar and the palette, and two 

additional paragraphs on asking for help (all testing materials are included as Appendix B). 

After reading the description, the user was given four tasks to perfonn, one at a time. The 

tasks were presented in a manner similar to the language questionnaire, as objects to be 

transformed. Language was not emphasized in presenting tasks to users, so as not to bias 

them toward choosing particular commands. The fIrst task was to underline text, the 

second task was to switch two paragraphs, the third task was to emphasize a line, and the 

fourth task Was to revise a badly worded phrase. 

As the users perfonned the tasks, facial expressions, comments, and mouse 

movements were recorded by the observer. After performing the tasks, the users 

completed a questionnaire. The questionnaire asked for the user's computer background, a 

description of the tasks performed (again gathering language), a description of unexpected 

word processor actions, and the user's general impressions of the word processor. The 

most meaningful data, in light of the design goals, was the observation of unfulfIlled 

expectations, and subsequent description thereof on the questionnllire. 
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The fIrst two users tested, Shannon and Alex, had not used a word processor before. 

Both had used the Macintosh a little bit for "class assignments." For the fIrst task, both 

users immediately clicked in the underline box in the palette, invoking the Instructions 

window (as no text had been selected). Both were considerably confused about the 

message, because it instructed them to "click where you want to begin typing in the new 

style, or select text to be changed to the new style." Both clicked, then pressed the OK 

button, and were swprised when the text did not change to the chosen style. After several 

tries, the observer pointed out the Select menu. Both tried the Select menu, and had no 

further problems with task 1. Shannon seemed upset that the text was still selected after it 

was underlined, but she clicked in the window to de-select, and then was happy. 

For the second task, both users were stuck until the observer reminded them of the 

help function. Shannon chose Help->Editing->Switching passages, then effectively 

followed the instructions. For the remaining two tasks, Shannon chose Help before 

attempting the task, then followed the instructions successfully (or botched the instructions 

and asked for repair help and followed those instructions successfully), While using the 

word processor, Shannon accidentally selected text. Instead of being surprised by the 

invened text (many new users are surprised and upset by selected. text), she realized that 

she'd discovered a new method, and thereafter used the click-and-drag method of text 

selection. Alex believed for a shon time that clicking would select for him (probably from 

his experience with the Select menu), then apparently remembered that he needed to choose 

from the Select menu fIrst. He performed the second task improperly, thinking that he only 

had to switch the words at the beginning of the paragraph. He therefore selected the 

words, then used the Delete rectangle in the palette, and retyped the words (the observer 

did not point out his error to him). 



24 

For the third task, Alex chose Select Some Text from the Select menu, but anticipated 

the instructions, clicking at the stan, then the end of the text he wanted to select (instead of 

clicking at the stan, then the OK button, after which he would be instructed to click at the 

end). He eventually got it right, and clicked in the Shadow rectangle in the palette. When 

the selected text changed to Shadow, he said that it looked awful. Later, when he de­

selected the text, he said "That's the way I wanted it to look." 

For the fourth task, Alex chose Replace from the palette, but he had text selected from 

the style change, so the replace didn't work. He cancelled, and used the Delete command, 

then retyped. 

For all of the tasks, both Shannon and Alex used the menu bar only to Select text. 

For all other commands, they used the palette. Shannon requested help, and was instttlcted 

to use the palette because she used the palette to underline text. Alex picked out commands 

from the palette independently of the help, and never chose a command he didn't intend. 

On the questionnaire, Shannon indicated that the word processor did nothing she 

didn't expect. Alex didn't understand why he had to choose from the Select menu after 

choosing all his other commands from the palette. Both wrote that they could use the word. 

processor in the "impressions" section of the questionnaire. Alex wrote "Even though I 

struggled for the fIrst few minutes, I picked up on it, and it became easy to work with. 

This was in a short period of time, so I don't think it would take very long to be able to use 

this effectively." Shannon liked the help, and wrote ''The directions given by the computer 

help you to know what to do." 

After Shannon and Alex, the design was improved in two ways. First, the style 

change message was reworded to be more explicit about when to select, and when to click. 
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Second, the selecting "after-effect" was removed. If text is still selected after an operation 

(such as Copy, or a style change) it is de-selected immediately by the word processor. 

The third subject had used an ffiM PS2 extensively, and had used the Macintosh 

some for word processing. Roben completed the four tasks quickly, probably because of 

his experience with selecting and his facility with the mouse. For the first task, he first 

clicked in the underline rectangle in the palette, invoking the Instructions window. After 

reading the message, he clicked at the beginning, and then the end, of the text to be 

underlined, then clicked in the OK button. After a moment of confusion, he dragged over 

the text, then chose Underline, and clicked in the OK button. He said that he knew to drag 

from "previous experience." 

For the second task, Robert clicked in the Move rectangle in the palette. When the 

Instructions window appeared, he selected the text he wanted to move, then clicked where 

he wanted it to go, anticipating the next set of instructions. He then re-read the 

instructions, and re-selected the text, following the Move procedure effectively. 

For the third task, Roben clicked in the Shadow rectangle in the palette, then selected 

the text, then clicked in the OK button. For the fourth task, he couldn't decide between the 

strike-out rectangle (Delete) and the scissors rectangle (Cut) in the palette. He fmally 

decided on the strike-out, and used that command, as well as the Replace command (from 

the palette) to reword the passage. Like Shannon and Alex, Roben used the palette 

exclusively for his editing and formatting tasks. Roben wrote that the word processor did 

nothing he didn't expect, and that it was "simple, completely laid out and direct. Very 

forward in approach." No changes were made to the prototype at this point. 
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The fourth subject, Bill E, had used a VAX lIngO, an mM mainframe, and an ffiM 

PC, but had never used a Macintosh. For the first task, he had an almost identical 

experience to Shannon and Alex, but preferred the Select Some Text option, where they 

chose Select a Word or Select a Sentence. For the second task, Bill first selected the text 

(using the Select menu), then chose Cut from the Edit menu. He then selected and chose 

Move from the Edit menu, thus losing the Cut text. He realized immediately that the 

Clipboard had been overwritten (the Clipboard was visible after the Cut operation), and 

repaired his mistake by retyping the text. Bill informed the observer that he had used a 

system in which "Move" indicated the same operation as Macintosh's "Paste." 

For the third and fourth tasks, Bill easily selected text and chose operations that he 

wanted to perform on the selected text. Unlike Alex, Shannon, and Roben, Bill preferred 

the menu bar to the palette, once he noticed it (the observer indicated the menu bar to Bill 

when he was stuck over selecting text). He admitted that the menu bar was described in the 

word processor description, but he forgot about it. Bill wrote that he "expected some 

problems selecting different options. Once I became familiar with how the system worked, 

it was more obvious and pretty easy." He also wrote that the user should be precautioned 

about what operations will change the contents of the Clipboard. No changes were made to 

the prototype at this point 

The fifth subject, James, is an expert computer and Macintosh user, and had no 

difficulty executing any of the tasks. James selected using the mouse, and chose all of his 

commands from the palette. He didn't like that the word processor "helped" him when he 

perfonned the first task (underlining), because he already knew to select before choosing a 

style. He wrote that the word processor was "fun to use." Four other subjects were tested 

the same day, so the prototype could not be changed at this time. 
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The sixth subject, Jeff, is a beginner on an ffiM PC compatible word processor, and 

had never used any other computer. For the fIrst task, Jeff misunderstood the instructions, 

and spent some effort changing a paragraph from plain text to boldface. Before he realized 

his mistake, Jeff tried the help function, which told him to use the palette (the default when 

the user hasn't actually done anything). Jeff tried to click in the "Change to" rectangle of 

the palette, which is an ornament and not a command. After realizing his mistake, Jeff 

chose underline from the Set Type Style menu, selected the text to be underlined, and 

clicked in the OK button. Surprisingly, Jeff had no difficulty selecting with the mouse. 

When questioned by the observer, Jeff said that it was "common sense." 

For the second task, Jeff chose Move from the Edit menu. His mouse-selecting 

procedure didn't work well for text longer than one line, because he didn't realize he could 

drag beyond one line (Shannon did the same thing, and operated on lines one at a time). 

Because of his diffIculties with the mouse, he chose Help (from the palette), and asked for 

help switching passages. After reading the Help, he successfully switched the passages. 

The Help told him to use the Move rectangle in the palette (because he hadn't done a similar 

operation previously), so he used the palette. 

For the third task, Jeff had no trouble emphasizing the phrase, choosing Bold from 

the Set Type Style menu. For the founh task, he tried the Clip->Text rectangle in the 

palette, realized his mistake, and tried the Text->Clip rectangle. He then cancelled that (the 

Instructions message made him realize he wanted to Cut, not Copy), and chose the 

scissors, successfully rewording the passage. In writing about his expectations, Jeff wrote 

"the computer did what I told it to do." His impression was "I believe that after working 

with it for a IDm:t period, I would be comfonable using it. It seems to take a lot of the 

thinking out of how to write something, in other words, it makes organizing your work 

easier." 
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Jeff clearly preferred text-oriented commands to the graphical palette, either because 

of a natural inclination, or because of his previous word processor experience. It was 

unfonunate that the help directed him to use the palette, although he had few difficulties 

adjusting to the palette. He hypothesized later that the palette was supposed to be used for 

editing commands. 

The seventh subject, Bill B., had previously used an IBM PC and an Amiga for word 

processing, but had never used a Macintosh. For the first task, Bill clicked in the 

Underline rectangle in the palette, read the instructions, selected the text, then clicked 

elsewhere in the window (de-selecting the text) and clicked in the OK button. He followed 

the procedure a second time but forgot to click in the OK button. He chose Help, realized 

his mistake (saying "duh"), and fmished the task. 

For the second task, Bill used the Move rectangle in the palette to successfully switch 

the passages. For the third task, Bill used the Bold rectangle in the palette to successfully 

emphasize"the sentences. For the fourth task, Bill chose Help / Edit / Reword, read the 

screen, then chose Help / Edit / Delete, and successfully used Delete and Move to reword 

the passage. Unfonunately, Bill didn't realize that he could type on the keyboard, so he 

spent a considerable amount of effon getting the spacing perfect in his revision. In the 

expectations portion of the questionnaire, Bill criticized the word processor because of 

these problems moving words (the Move is not implemented. "intelligently," leaving spaces 

where it should take them). His impressions were that "it worked pretty well, and really 

didn't give me any more trouble than most. I was a bit unsure about one of the symbols 

(the delete symbol) on the palette, but it really was no big problem." 
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The eighth subject, Brian, had previously used an ffiM PC Compatible, a Macintosh, 

and an Apple lIe for a variety of purposes, but didn't consider himself an expert on any of 

these systems. Nevertheless, he had no problems" with "the tasks, using the drag method of 

selecting text, preferring the palette to the menus, and using the Cut and Paste commands 

rather than the Move and Replace commands. Like James, he didn't like the Instructions 

message that appeared after a formatting command, telling him ~ select or click after he had. 

already selected. His general impressions were: "I thought it was good. However, I think 

the palette needs to be clarified (functions listed in the instructions). Of course, this may 

have been in the 'Help' section of the program but I didn't use it." 

The ninth subject, Sarah, is a frequent MacWrite user, but has never used any other 

computer, and has had little contact with other software for the Macintosh. She, like Brian 

and James, had. no difficulty accomplishing the tasks. Sarah used the menu bar for the first 

two tasks (preferring, like Brian, the Cut and Paste commands to the unfamiliar Move 

command), but she used the palette for the third task, and used only the keyboard and 

mouse for her revision of the sentence in the fourth task (her revision was the most 

extensive of all the users tested). Sarah, like Brian and James, wrote that she did not 

expect "to have to hit 0.K. after changing word styles." 

After James, Jeff, Bill, Brian, and Sarah, three changes were made to the prototype. 

Because the select "side-effects" were removed, there was no longer any reasonable 

ambiguity about the user's intentions when selecting text and choosing a text style. 

Therefore, selecting text prior to choosing a text style is considered valid information about 

the user's general strategy of object and operation selection timing. Thus, the Instructions 

window no longer appears if the user selects text before choosing a text style. 
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Two intrusive dialog boxes were added. Several of the users tested tried to choose 

commands while the Instructions window was still up (Le. they forgot to click OK or 

Cancel). One message was added instructing the user to click in the OK button or the 

Cancel button before choosing the new operation. A second message was added because 

of Jeffs confusion over changing type styles in the palette. The message appears if the 

user attempts to click in the "Change to" ornament, instructing the user that it is not a 

command. This is not intended as a fix to the problem, but more of a bypass. Since 

everything else in the palette is a command, the "Change To" ornament should be removed. 

Conclusions 

Despite a variety of backgrounds, none of the users required more than a half hour to 

complete the four tasks, and most used much less rime. Each of the nine users developed 

his own strategy for solving problems with the word processor, and no strategy or method 

was preferred by a majority of the users. 

Users who had previously used the Macintosh, but were neither novices nor experts, 

seemed most comfortable with the familiar commands. The Macintosh expert explored the 

new commands provided by the prototype. The novices preferred the palette, whereas the 

previous computer users tended to use the menu bar. The users familiar with the 

Macintosh chose the object before the operation, the other users tended to choose the 

operation before the object 

From this data, it can be concluded that the design provided options which were 

comfortable to a variety of users, without being "cluttered." Conflicts arose only when the 

help system provided the user with advice which forced him to act against his natural 

inclinations. Only one user, Brian, used the word processor in a manner that seemed to be 

contrary to his preconceptions. Brian used the palette versions of the standard Macintosh 
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commands and criticized that the meaning of the palette options wasn't clear. Why didn't 

Brian use the menu bar, where the commands are named in the same way that they are in all 

Macintosh word processors? It is possible that the palette is distracting, causing users to 

forget the less flamboyant menu bar. Another user, Bill F., didn't notice the menu bar, 

even though it was described in the word processor description. It is also possible that 

Brian assumed that different commands would be provided in the palette and the menu bar 

(a natural assumption), and the palette looked like it provided the Cut, Copy, and Paste 

commands. 

All users were able to choose the operations they wanted, but the non-eomputer users 

had difficulty selecting objects, as was expected. Can the "bootstrapping" methodology 

help the user who has no preconceptions about objects, operations or strategies? The non­

computer users were able to select once the Select menu was revealed to them, but the 

notion of selecting was not as natural to them as it was to previous computer users. The 

"bootstrapping" methodology needs to be better developed to effectively treat areas in 

which preconceptions and previous experience may be weak or missing. 

The help ponion of the prototype demonstrated that conf'rnnation of a user's 

preconceptions assists the user in developing a consistent mental model of the software, 

through both positive and negative examples. Bill B. was pleased to discover that the 

procedure he was following was the correct one, when he asked for help completing a task 

with which he was having difficulty. He indicated that he had missed something obvious, 

but to another user, his method. would not have been obvious at all. Jeff had the 

unfortunate experience of receiving advice which was counter-intuitive, and subsequently 

developed an inconsistent model of the prototype (editing commands must be chosen from 

the palette, even though they seem to be contained. in the Edit menu, but formatting 

commands may be chosen from the Set Type Style menu). 
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A design methodology which accounts for user preconceptions and tutors problem­

solving based on preconceptions appears to be a viable alternative to single-model interface 

design, at this early stage of development. The users tested developed their own methods 

for achieving tasks, and all successfully achieved the assigned tasks. More work must be 

done to improve the methodology itself, in order to handle areas in which preconceptions 

are weak or missing, and to tutor users who haven't used the system much, but request 

help. 

Future Directions for This Research 

Improvements to the Prototype 

Before a final design is developed and tested, more usability testing has to occur. A 

different version of the prototype should be created and tested. with the following features: 

• Method and task refinements 

Some of the tasks should be altered, and the methods for accomplishing the tasks 

should be refmed. For example, There should be several different Replace Text methods, 

instead of one: Replace some text, Replace a lot of text, Replace while you're typing, 

Replace text that is far from the insertion point The user may backspace frequently while 

typing, to replace small errors, but this is not an appropriate-method for replacing a large 

block of text. The help system will tutor this method, however, because the user employs 

it frequently, even though the user may wish to learn a method appropriate to a different 

kind of replacing. 
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• "Intelligent" Move and Replace commands 

Move and Replace currently move and replace the selected text, instead of checking to 

see if the selection includes spaces, tabs, and carriage Teturtls which should be part of the 

move or replace operation. 

• Palette selection 

For the users who use the palette exclusively, a select option should be included on 

the palette. Research should be done to determine the exact nature of this option. 

• Help changes 

In the help procedures, the user's growth should be considered. A button could be 

provided to teach an alternate method to the method the help system thinks the user should 

learn. Task achievement methods should be weighted and losing weight over time, so that 

as the user learns, he isn't plagued by his early conceptions. 

The help windows should include options not only about the commands available 

with the word processor, but also commands for getting staned, for typing text so that it 

appears as desired. and for managing invisible characters. 

Help currently uses as a last reson (if the user has tried nothing relevant), how the 

user chose Help. If the user chose from the menu bar, he is instructed to follow a 

procedure using commands from the menu bar. Similarly, if he clicked in the Help button, 

he receives help suggesting he try commands from the palette. Help should be changed to 

look for a general trend in palette I menu preference instead of looking at how the user 

chose Help, as evidenced by Jeffs unfortunate conclusion that he should use the palette for 

editing tasks. 
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Help should be improved to consider incomplete procedures, especially incomplete 

procedures before choosing help, to emphasize to the user th«t the incomplete procedure, or 

a repaired version of the incomplete procedure, can lead to a successful completion of the 

task. Bill B. was relieved to learn that his method of changing the type style, which he had 

tried once without success, was the proper method. One way to find incomplete 

procedures is to record what happens before the press of the Cancel bunon. 

The Final Design 

The fmal design will contain the interface, user-computer interaction method, and 

user model developed through the usability study of the user audience on the prototypes. 

With more time and resources, experimental help techniques could be substituted for the . 

method currently in use. There are many possibilities for the help system which could 

improve user comprehension and satisfaction with the help provided. 

Research indicates that instructional events usually fail because the instructor has 

made an assumption about the user's knowledge of prerequisite information (Hill, 1989), 

or because users are unable to formulate a follow-up question (Moore, 1989). A solution 

to these problems might be a user-computer interaction strategy in which dialogues are 

composed of brief explanations created from hypertext or offering hypenext-like choices. 

Hypertext offers the user the possibility of definition of unfamiliar tenns, or description of 

unfamiliar procedures which appear in a help dialogue. 

Carroll et aI. recommend using task-oriented language in instructional design in order 

to coordinate learner's goals with procedure descriptions ~Carroll, Smith-Kerker, Ford. 

Mazur-Rimetz, 1987). Carroll and Mack et al. have found that keeping suggestions 

incomplete improves user competence in learning and task perfonnance (Carroll, Mack, 

Lewis, Grischkowsky, Robenson, 1985). They hypothesize that if suggestions are 
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incomplete, following instructions does not replace the users original task-oriented goal. 

Instead of modal help windows, incomplete suggestions could be provided in non­

disappearing windows, so the user could refer to the help as he attempted to carry out the 

task. 

In order to study user interactions with prototyped situations, a recording facility 

superior to the current method must be available to the designer and invisible to the user. 

The recording facility will save on disk keystroke c4ita for situation sessions, available for 

"play back" on the software. Necessary features, such as "pause," will be identified and 

provided. 
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WP Event Type From Means 
nullEvt no event took place 
Select menu chose Select from menu 

mouse press&drag or double-click 
key shift key to extend selection 

ClickDnArrow clicked in scroll bar down arrow 
ClickUpArrow clicked in scroll bar up arrow 
ClickDnArrowRepeat repeatedly clicked in scroll bar dn arrow 
ClickUpArrowRepeat repeatedly clicked in scroll bar up arrow 
PressDnArrow pressed in scroll bar down arrow 
Press UpArrow pressed in scroll bar up arrow 
DragThumb press in thumb area of scroll bar 
ScreenP menu chose Previous Screen. from View menu 

key use cmd-key equivalent to menu 
mouse clicked in ScreenP area of scroll bar 

ScreenN menu chose Next Screen from View menu 
key use cmd-key equivalent to menu 
mouse clicked in SereenN area of scroll bar 

LineP menu chose Previous Line from the View menu 
key use cmd-ltey equivalent to menu 

LineN menu chose Next Line from the View menu 
key use cmd-key equivalent to menu 

PressOK press in OK button 
PressCancel press in Cancel button 
SizeSet menu w/out text selected, chose size from menu 

palette w/out text selected. chose size from pal. 
SizeChange menu with text selected., chose size from menu 

palette with text selected, chose size from pal. 
FontSet menu wlout text selected. chose font from menu 

palette w/out text selected. chose font from pal. 
FontChange menu with text selected., chose font from menu 

palette with text selected., chose font from pal. 
StyleSet menu w/out· text selected.,chose style from menu 

palette w/out text selected, chose style from pal. 
StyleChange menu with text selected, chose style from menu 

palette with text selected, chose style from pal. 
Replace menu chose Replace from the Edit menu 

palette chose Replace from the palette 
Delete menu 

palette 
Move menu chose Move from the Edit menu 

palette chose Move from the palette 
Duplicate chose Duplicate from the Edit menu 
Copy menu chose Copy from the Edit menu 

key use cmd-key equivalent to menu 
palette chose CopY from the palette 

Cut menu chose Cut from the Edit menu 
key use cmd-key equiValent to menu 
palette chose Cut from the palette 

Paste menu chose Paste from the Edit menu 
key use cmd-key equivalent to menu 
palette chose Paste from the palette 

UserTxpe typed a character key 
DeleteTYpe pressed the delete key 
MovelP clicked in the text edit window to move IP 

Table 1: Word Processor Event Types 
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Goal Method 
Delete Text (1) 

(2) 
(3) 
(4) 

Put IP (insertion point) at end. press the delete key 
Select, press the delete key 
Select, choose Delete 
Choose Delete, select 

Cut Text (1) 
(2) 

Select, choose Cut 
Choose Cut, select 

Paste Text (1) 
(2) 

Choose Paste 
Novice Paste (Instructions window) 

Copy Text (l) 
(2) 

Select, choose Copy 
Choose CopY, select 

Duplicate Text (1) 
(2) 
(3) 
(4) 

Select, choose Duplicate 
Choose Duplicate, select 
TOC (text on the clipboard), Move IP (moveip, type, etc), Paste (1) 
TOC. Move IP. Paste (2) 

Replace Text 

Move Text 

(1 ) Delete (1) and retype 
(2) Delete (2) and retype 
(3) Delete (3) and retype 
(4) Delete (4) and retype 
(5) TOC:Cut and retype 
(6) Select and retype 
(7) Select and choose Replace. then type. etc 
(8) Choose Replace. then select, etc 
(1) TOC:Cut, move lP, paste (1) 
(2) TOC:Cut, move IF, paste (2) 
(3) TOC:Copy, delete (2), Move IP, paste (1) 
(4) TOC:Copy, delete (2), Move IP. paste (2) 
(5) TOC:Copy. delete (3), Move IP. paste (1) 
(6) TOC:Copy. delete (3). Move IF. paste (2) 
(7) Select and choose Move 
(8) Choose Move and select, etc. 

View (1) ScreenP. ScreenN 
(2) ClickUpArrow, ClickDnAIrow 
(3) ClickUpArrowRepeu. ClickDnArrowRepeat 
(4) PressUpArrow, PressDnArrow 
(.5) DragThumb 
(6) LineP. LineN 

Change Text (1) Select and choose Size 
(2) Select and choose Font 
(3) Select and choose Style 
(4) Choose Size and type 
(.5) Choose Font and type 
(6) Choose Style and type 
(7) Novice choose Size. select or click (Instructions) 
(8.) Novice choose Font, select or click (Instructions) 
(9) Novice choose Style. select or click (Instructions) 

Table 2: Methods for Task-Achievement 
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Questionnaire 

1. Approximarcly howmmy dnAa do you write? 

2. What do you UIC 10 write? (chccll: CIIIe) 

o Only pm I pcocillDll ~ o Pm I pen:illDli P-IICr Ind • typewrircI' 

o 0nIy.~ o Pm I pencillDli P-IICr Ind • word procca..­
o Only wont proceaar 
o ~ aDd • word pI'OCIeIICIr

O<Aher 

3. Briefly dercribe your method (p.-OCCSI) of wriIing: 

Answa' questions 4 and 5 only Ii you have used • word processor. 

4. What wonI proceslOn baYe you uled? (chcc:Ir:: u _, u apply) 

o MaciDlolh· MacWriIe 
o MacidDlh· MS Word 
o Maciraolb· ada o IBM PC - MS Word 
o IBM PC . HBJ Wri~ o IBM PC - odla Whatooc? o VAX-EDT o VAX-oeM What one? 
O<Aher 

5. Whar. ward procesIClI" do you UIC IIIlIat of1aI? (chec:lc OIIe) 

o MaciDlolh· M-eWriIe 
o Maciraolb· MS Word o MaciNoIh· ocIB o IBM pc. MS Word o IBM PC . HBJ Wri~ 
o IBM PC . odla o VAX-EDT 
o VAX - ochr:r 
O<Aher 
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The remaining qualians (6 • 31) alIlwve the smJe formaL 1'bCre wiU be two picmrea, one in the "Before" column, mel 
oae in the "After" coIwnn. Below the pidUrea tbcI'e will be linea on which-you IbouIcl wrUe wlwl was done to make the 
"Before" picture loci< like the "After" piauR. Fa eXlmplc, look alb two piCllllU lIdow: 

BEFORE AFTER 

Sow consider the following ex.anple: 

BEFORE AfTER 

:~ trere is are thirg I :f tle:e was one tl"':"ng I 
.:an't st:and... can I t st.an:i•.. 

lflhilwerep-n of the C!ueslIllrW!Ue; [migt& write: '"'The W<lni 'is' hu been fel'I8CCld." I migt& also write "the _ 
hal been changed., incom:cUy, £rem prcaem to put_" Although thi. i. carec:t, I do l1Dl W8l1l grmunu.ical . 
commaus. I pr'ef~ commmlS of the f1m kind. descnbing wlwl bas clwtSed in !he "Befcre" picuue to mai::e It 100II: lib 
the "Afur' picwre. 
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6. 

What he had once hooed for What he had 
the Flock... 

once hoped for 
the Flock... 

g 

~nac ~e ~da ~~ce ~C?ea :c= :he 
?:CCK, ~e ~~w qal~ea ~~= 

~:~se~: :~~~e: ~e ~ea=~ed to 
~:y. d~a ~as ;.c~ 50r~1 ~or t~e 

~r~ce :~a~ ~e palO. ;~~athan 

5eaqu.~ c:scove,ea :;.ac 
=o=eac~ d~a :ea, a~a a~ger are 
:~e :easc~s :~a~ a ~~.~'3 ~:~e 

~s so s~o~~. ~~c ~~:~ :~ese 

~or.e ::~~ ~.s :~8~qr.:. ~e 

_:'";ea G .';~.a ::":-:e ~:..~e :..:--:o.eeo. 

~~at he had once hooed :cr 
:he Flock. r.e now q31nea :cr 
~imself alone: r.e Cear;.ea -~ 

:~Y. and was not sorry :or 
:he price chat he paid. 

:cna~han Seagull d~sccve,eo 

:hat boradom ana :ear d;.a 
~nqer are ~~e ~easc~s ~~a~ ~ 

~~~:IS ~::e ~s sc S~~=~, .:.~.-~ 

'itit.t :.~ese q:one ::::::-:": :"'.:'3 

~;.c~cn~. r.e c~vea a _c~c 

~ ~:e :~.:::eea. 

Nhat :-,e had. once ... 
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10. 

II. 

What he had once hoped for What be bad once hooed lor 
the Flock... the Flock. 

12. 

.	 ;....·Mi-_-iiiiii-f*-~­
iU."~'" ... - ........... ~ 
i"' • --., .. -... ~ 
:n... --_- .!U.,., ,....,
!.-_ •••.II 011_
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i:rr:.-;T,~:=-::~~-:n..: ~ 
i..• ..• N • : 
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j __ ....... ctl _
 

: ~--_ ........
 
\:ft':.-;!,:,!.r:-::,.::-~~ ;
i -4 .. 
;~" li I.. f'.l_ 

~.--.!.!..!!!.-!~--_ _ _­

-t._­
~~........ --.
 
i:::',:.:: ~~~.~ 

; 

!"",""el...; ,.; 
!== ~~'I.:-- :,- ,....,.....\ ....,..-.... 
i_'-II
l t
i f
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i 
~ 
. 

\,........ L...... 

i 
~J_.II 
....c ....... ".L .; 
.......... 4.......
a-.... .= 
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 .._-'!-------_.;-_....~ 
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13. 
What he had once hoped for 
the rlocK. ~e now gained for 
himself alone: ~e learned to 
fly. and was not sorry for 
t~e price that he paid. 

~onathan Seagull discovered 
that boredom and fear and 
anger are the reasons that a 
gull's life is so short. and 
with these gone from his 
thought. he lived a long fine 
life indeed. 

What he had once hoped for the 
rlOCK. he now gained for 
himself alone: ~e learned to 
fly, and was not sorry for the 
orice that he oaid. Jonathan 
seagull discovered that 
boredom and fear and anger are 
the reasons that a gull's life 
is so short. and with these 
gone from his thought. he 
lived a long fine life indeed. 

14. 

ia1at re had. What re had. once 
h:iped for the tq:led far the 
Fleck... Fleck... 

IS. 

What he had once hoped for 
the FlOCK. he now gained for 
himself alone: he learned to 
fly, and was not sorry for 
::-.e price that. he paid. 

;onat.han Seaqull discovered 
that boredom ana fear ana 
anger are the reasons that a 
~~ll's l~fe :5 so snort. and 
~lth ~hese gone £=cm his 
:~ouqnt. he c~ved a lcng fine 
~':':e ::""ceea. 

What he had once hoped 
for the Flock. he now gained 
for himself alone: he 
learned to fly. and was not 
sorry for the price t.hat. he 
paid. 

;onathan Seaqull 
discovered that ~oredom and 
fear and anqer are the 
~easons ~hat a ~ll's ~~:e ~s 

so short. and with these gone 
from his thought. he l~ved a 
long fine life i~deed. 
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16. 
En4jllish 101 9/16/89 

17. 

What he had once h<¢. 
for the Flock, ;'!e n.c1N 

gaired for hirnself 
al~... 

What he ~ once hcped 

for t.'1e Flock, he now 

gaired for himself 

alone... 

18. 

nnat ~e ~aa c~=e ~8~ea ~=~ ~nac ~e haa ~~ee ~CDea :0: 
~e ?:CCKr ~e ~CW ~al~ea :~: :~e ;:CCK. ~e ~cw qal~ea :~= 
~~self a~cr.e: ~e ~ear~ea ~_ ~:mseif a~cne; ~e ~ear~ea 
:y, a~d ~as ~o~ sor~y :~~ ::.v, and was :'".OC sc:r"' :::: 
~e ~r:ce ~~a~ ~e eaia. ~~e ~r1ce ~~at ~e palo. 

:cna". " 
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19. 

ZD. 

Jonathan Livingston Seogul 
a story 
R i ehard Bac:h 

JOnathan Livingston Seoqul I 
a story 

Richerd Bach 

21. 

~ac ~e had once hcpea ~or	 Whac he had once ho~d :or 
th ... 

12. 

s~.,., 1989 
Expenses 

May $260 
June $325 
July $400 
August $3~ 

Total $13f>0 

S~.,., 1989 
Ex~ 

$260 
$325 
$400 
$375 

Tolal $ 13f>0 
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What he had once ...waht he had once ... 

14. 

mat he had once h~ 

::% me Flock, r.e na..r 
~ned. for rJ..mself alene: 
~e iearned to fly, and 
".was not:. sorry for t..":e 
;:ric:e that !',e paid. 

15. 

Wha1 he had once hoped fer 
"-he ~ieCk, ne !'lOW 9air.ea fer 

rurnsel i a/one: he /earr.ec ~e 

iiv, ur.a was 1101 sorry .fer 

the r;nce '-ha1 he paid. 

'iJhat he had once hqJe:i 'Nhat he h3d once l"x:rp:!d 
:or L":e Flock, :-.e new q:::;t. :or t..'Je Flock, r.e" new 
:or only himself: gaired. for hiInself alone: 
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~7. 

Wha~ ~e ,-aa croce ~c~ec :cr 
:~e F:cc~, ~e ~ow galned for 
~:mseif a~~~e: ~e :ea=~ea ~­

:~y, a~a was ~~t s~r=y :cr 
:~e ~rice :,-a~ ~e ~a~d. 

;onathan Seaqu~: ciscovered 
~~a~ boreaom and :ear and 
anger are :~e reasons :~at a 
gull's :::e ~s so shore. and 
~ith these qcne :rcm nis 
though~. :~e ~:"/ed a :'eng ::ne 
':'.l.fe ~ndeea. 

;ona~han Seagull discovered 
:~at boredom and :ear ar.a 
anger are the reasons :r.a: a 
qull's :'ife is so snort. ar.a 
~ith :~ese gone frcm r.:s 
thought. he lived a :'cng ::r.e 
~i:e :":1Oeed. 

What he had or-ce hooea for 
:he Flock. he now galned fcr 
himself alone: he learned _~ 

:ly. and was no~ sorry fer 
the price that he paid. 

:8. 
What ~e l".ad cnce :-,a:e:i What he had. once h:lpe<i 
::or the Fleck. r.e now ::or 1:.'1e Flock, ~e r:.0tl 

gained fer hilrlself alone: gaiood for himself alone; 
he learned :'0 fly, an:i 
was not sorrj for t...'1e 
price t..'1at l"'.e paid. 

:~I:: ====-; 
.....:=1, 
: I: 

'~I: 
.--1; 
-:=1· 
:~I:

:--1; 
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30. 

What he had once hq:led 
for the Flock, he no.l 

gained. for himself alone: 
he learned to fly, am 
was not sorry for tl'.e 
price that he paid. 

What she· had once hoped. 
:or the Flock, she rr::iW 

gained. for himself alo~; 

she lea.rNad. to fly, and 
was not SOrrj for the 
price t.h:l.t she paid. 

31. 
~bat ~e ~aa c~ce nopea ~cr 

~he F:~CKr ~e ~cw gai~ea ~~r 

~imseif aic~e; ~e iea!T.ea ~o 

~:y, a~d was ~c~ sorry ~or 

~~e c=:ce ~~at ~e ?alC. 

~e iearned co fly. Nhac te 
~ad cnce ~oped fer the "~ock. 
~e r.ow gained for himself 
alone; and was noe sorry 
:or ~~e price ~~a~ ~e palda 
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Please don't read this page until you've finished 
the questionnaire 

Thank you foe fillin& QUt my q\lC$li.aonaire. It is designed 10 discover the kind 0( Impage yClll lise foe leU­
<Il1nipulalioa IaIltL I am developing, fex my MUla's thesis, Aw«d processor which wi" be easy fOS' people 10 lean, 
eSllCCwly people who ..e not paruClli..ly food 0( eanputen. If I c.on discova Ulc kind 0( Imguge difffftd peopIc IIIC 
to refer 10 Iext-mUllpulllion taslcs, lhen my worcI-proc:cs5Ol' Q/llise lhallanguage 10 ecmmllnicalc with diffac:lll people. 

After I have develoflcd lbc wexd proceasot" (NaYembel" OS' December), I 'Nill tal it: Thil will auil awroximaldy one 
hour of Iccning I using !he word processor foe C8Ch person in my swdy. If you migbl be iIUI'eIled in IIsing !he word 
prOCell« I develop, OS' Ii you have any quc.suons abou1 this swdy, leave your aame aad plume aumber below, 

Same:
 

.!------J' _
 
Phone number. 

Pluse do not call before: 

Pluse do not call &l'u:r. 

and check one or both of \he foUowing: 

I have qlleAlON about your sWdy: __ 

I mi&bl be inJc:reoud in pu1ICipeung fIInher in your RUdy: __ 

If you bAn Iny comments about Ibil quesUoctnalre or the aature 01 my study, please Include 
tbem below and CODUaue OD tbe back of Ibis page. 
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The Word Processor 

This is a word processor which is designed to be easier for the beginner to learn 
than coltllMt'Cially available word processors. It is the word processor that is being 
tested, Nor you. You were chosen to test the word }X'OCea1Ot becllUSe you Ire a 
beginner. Don't feel bad if you don't know how to do something, or can't figure 
out how to do something. 

On the screen. you will see a "window" which contains an essay. Using the word 
processor, you will be able to change the appearance and text of the essay. 

The Mouse 

The device next to the keyboard is called a "mouse." When you rmve the mouse, 
the cursor moves on the screen. You can use the mouse to choose commands and 
to move the text cursor which is inside the window. You will use the text cursor to 
indicate what text you want to perform operations on. 

Giving Commands 

• Help File Edit Select Ulew Set Type StYle 

Across the top of the saeen is the menu bar. 'The words in the menu bar are menu 
titles. Menu titles desaibe the items found in menus. For example, items in the 
Edit menu are editing opc:rlIions; items in the View menu are options for viewing 
your documenL 

To choose from a menu. superimpose the arrow over the menu title and p-e5S down 
on the mouse bunon. TIle menu is ''pulled down" and you can see the menu items. 
Hold the mouse button down while moving the pointer down to the menu item you 
wanL When the item is displayed in inverse, release the mouse button. 

The Palette 
11le paleue also coruains commmds. Point 
to the command that you want in the palette, 
and click to choo&e it. The palette contains 
buttons as weil u c:ommmds (the rectangle 
WIth the word Help is a button). To 
"press" a butlOn.. point to the button and 
dick. 

( Help 

ClIp -. Teet 

Text -. Clip 

0-. to: 

Chicago 

Gettlnl Help 

[f at any time while you are using the word processor. you feel you need help, 
choose from !he Help menu or cli<;k in the Help button in the palette. Choose the 
kind of help you wam. then read the screens that follow. After you are done 
reading. you cm use the word processor again. 

Since the screens cannot be up while you are using the word p-ocessor. feel free to 
lake notes if you ftnd it necesscy. 
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Instructions 

1. At the top of the screen, you will sae the heading 
"Traits," like this: 

Traits 

)sn' it remarkable that words can portray human individuals? You 
mIght suppose this should be impossible... 

Change the heading so It looks like this: 

Isn' it remarkable that words can portray human individuals? You 
might suppose this should be Impossible... 
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Instructions 

2. In the essay. there is a section which begins with 
"Selectivity:" and another section which begins with "Style:". 
They are as follows: 

Selectivity: First we should face the fact that our images of other minds 
are often falsely clear.... 

Style: To escape the effort of making decisions we oonsider 
unimportant, we tend to deve!op .. ­

Change them so they are like this: 

Style: To escape the eHort of maKing decIsions we oonsider 
unimportant. we tend to develop ... 

Selectivity: First we should face the fact that our images of other minds 
are often falsely clear.... 
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Instructions 

3. Th.....y contaIn. the followIng lin.: 

Hostility evokes defensiveness. Frustration arouses aggression. 

Make the lin. stand out mor•. 
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Instructions 

4. The last sentence In the text 18 badly worded. It 18 aa 
follows: 

There is a sentence. that which is a little confusing, and it is positioned 
after the Minsky citation. 

Reword the sentence so It Is eaaler to read. 
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Questionnaire 

If you have used computers before. list the comouters you've used, what 
you've used them for, and rate your proficiency on that computer. List only the 
computers that you use the most. 

Computer 
What you use it 101 
Proliciency rating (ade one) i

8eQ=--'IY\CIf---L-----I·----L.----:E'""x-pQn 

Computer 
What you use it 101 
ProfICiency rating (ade one) I I8eQ=--,-IY\CIf-------- -----L---'='Ex-pen 

Computer
 
What you use it 101
 
ProfICiency rating (ade one)
 

Expen 

Briefly describe the four tasks that you perlormed on the word processor
 
today. telling what you were supposed to do, not how you did it:
 

When you tried to accomplish the four tasks on the computer, did the computer 
behave in ways you did not expect? DesCribe what you expected the . 
computer to ~o. compareo to what It actually did: 

Briefly describe your impressions of the word processor: 
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Options File (by segment) Size Options File (by build order) Size
Interface. lib 8104 Interface.lib 8104Runtime.lib 18258 Runtime.lib 18258[[lID V R Quickdraw.p 0 [[lUI V R Quickdraw.p 0[[I[EI V R Toollntf.p 0 lIiJ£tI V R Toollntf.p

[[I1Dl2JlS Editor Globals 0 0
[DJUI[2I[B Editor Globals 0

[[IID~ Editor Main 66 [[II'fI'Si![fI Open Palette 1710Segment 1 26432 [[I1DI2lID Editor Utilities 4884~ Open Palette 1710 lIiJlDlSdUl Editor Help Init 3016[QIIEU2][B Editor Init 3960 [DJIDUIB Help Filing 125·44Segment 2 5670 [DJID[2I[fI Help Bests 23702 
~ Editor Utilities 4884 [dl ijlvll A help bests 2 
[]I1EI[2][B Help Filing 12544 676 

lIiJrEjLYJ[fI Editing Help 
[QII]I[21IB Editor Help 3 10390 4580 

[QI1DI2lID Editing Help 2 19220
Segment 3 27818 lIiJ£tILvlLB Editing Help 3 12134

[]IiEi~ Editor Help 2 16634 [DJ[D[2J[fI Editing Help 4 3874
[O]I]I~ Editor Help 8202 lIiJW![2ILB Editing Help 5 6804Segment 4 24836 [QI[Ej[2l[B Format Help 11626 
~ Help Messages 30 12 [QI£tI[2I[fI Format Help 2 11668

Segment 5 301 2 [DJ1DmII:B Format Help 3 11670mmmm Help Bests 23702 [[IlDlSdlD Help Messages 3012[[I[N13lJ(B help bests 2 676 [[IDVJlB Editor Help 2 16634
Segment 6 24378 .[DlNMD Editor Help 3 10390 

~ Editor Help Init 30 16 [DJ£tIlSlIB Editor Help 8202[DIIEU2][B Format Help 11626 lIiJ[fIYJ(B Show Edit 
[DIlEI[2I[B Format HelD 2 11668 [DJ[g[2I[B 

1120 
Edit Records 

Segment 7 26310 [QI[H[2I[EI 
1310 

Change Font 5688 
~ Editing Help 4580 lIiJlDlSdrEI Editor Init 
[DI1El~ Editing Help 2 19220 1!lI£tI[2I[B 

3960 
Editor Toplevel 22630

Segment 8 23800 l!lI[HlSdID· Editor Main 66 
~ Show Edit i 120
 
[DI1EI!mJ Edit Records 1310
 
[DI~ Change Font 5688
 
[o]1EI~ Editor Toplevel 22630
 

Segment 9 30748
 
~ Format Help 3 11670 

Segment 10 11670 
TImIm Editing Help 3 12134 
CEilIEI[2I[B Editing Help 4 3874 
w1[E![2llB Editing Help 5 6804 

Segment 11 22812 
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